DNS resolution issues resolving COS hosts

Incident Report for Cross River

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 19:31 EDT

Monitoring

The issue has been identified to our DNS host and has affected many services across the Internet. This affected DNS resolution of the COS crbcos.com domain.

All our internal alerts have closed but we are continuing to monitor. We will update again if necessary.
Posted Jul 14, 2025 - 18:47 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 14, 2025 - 18:45 EDT

Investigating

We have detected a potential disruption of COS services. Our technical teams are currently investigating and will update with details as soon as they become available.
Posted Jul 14, 2025 - 18:05 EDT
This incident affected: COS Production (ACH API, Card Management API, Checks API, Core API, Debit Card API, RTP API, Webhooks API, Wires API, XPay API, COS Portal).