Disruption of COS services

Incident Report for Cross River

Resolved

This incident has been resolved.
Posted Mar 30, 2025 - 08:52 EDT

Identified

We have identified the root cause, and we are currently fixing the issue
Posted Mar 30, 2025 - 08:30 EDT

Update

We are continuing to investigate this issue.
Posted Mar 30, 2025 - 08:18 EDT

Investigating

We currently experiencing a disruption of service.
We are currently investigating and will update with details as soon as they become available.
Posted Mar 30, 2025 - 08:03 EDT
This incident affected: COS Production (ACH API, Card Management API, Checks API, Core API, Debit Card API, RTP API, Webhooks API, Wires API, XPay API, COS Portal) and COS Sandbox (ACH API, Card Management API, Checks API, Core API, Debit Card API, RTP API, Webhooks API, Wires API, XPay API, COS Portal).