Investigating Issues Affecting OFAC Screening Services

Incident Report for Cross River

Resolved

This incident has been resolved.
Posted Jul 11, 2026 - 13:50 EDT

Monitoring

The compliance scan degradation issue appears to be resolved. We are working with the provider to identify the root cause and continue to monitor the service
Posted Jul 11, 2026 - 12:51 EDT

Investigating

We are currently investigating degraded performance with customer compliance scans.
Posted Jul 11, 2026 - 12:36 EDT
This incident affected: COS Production (Core API).