Cross River Incident - FedNow Payments delayed
Incident Report for Cross River
Resolved
We temporarily lost connectivity to the FedNow servers. Connectivity has been restored and our services have come back online.
Posted Apr 02, 2024 - 08:01 EDT
Investigating
We're experiencing delays in delivering FedNow payments. We're investigating and will post an update as soon as possible.
Posted Apr 02, 2024 - 07:45 EDT
This incident affected: COS Production (RTP API).