We are currently investigating a disruption of COS services

Incident Report for Cross River

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 11:56 EST

Monitoring

We have identified the root cause of the issue and initiated the fix. The service is currently being monitored to ensure it is functioning properly.
Posted Nov 10, 2025 - 11:43 EST

Investigating

COS is currently experiencing a disruption of wires. We are currently investigating and will update with details as soon as they become available.
Posted Nov 10, 2025 - 10:53 EST
This incident affected: COS Production (ACH API, Card Management API, Checks API, Core API, Debit Card API, RTP API, Webhooks API, Wires API, XPay API, COS Portal).