We are currently investigating a disruption of COS services

Incident Report for Cross River

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 13:24 EDT

Investigating

COS (Checks API) is currently experiencing a disruption of service. We are currently investigating and will update with details as soon as they become available.
Posted Mar 24, 2025 - 13:21 EDT
This incident affected: COS Production (ACH API, Card Management API, Checks API, Core API, Debit Card API, RTP API, Webhooks API, Wires API, XPay API, COS Portal).